Cannot start service SPUserCodeV4 on computer…!!!


Recently I started testing out SharePoint Online solutions. Its really hard to develop a webpart and test and debug it on Online itself(Because you need to upload solution, activate manually again and again). So I am using my SharePoint server installation and deploying my custom development as sandboxed solutions and then debugging them. When the webpart looks good I go deploy it on SharePoint Online.

When I created my first sandbox solution and try to deploy through Visual Studio 2010 it prompted me with an error.

Error occurred in deployment step ‘Activate Features’: Cannot start service SPUserCodeV4 on computer ‘KAMILSP2010’.

So I figured out this is something to do with missing of a service that needed to deploy or run any sandboxed solution. Little bit of googling helped me to sort it out the issue.

To resolve this you need to navigate to
SharePoint Central Administration –> System Settings –> Manage services on server

then search for the service “Microsoft SharePoint Foundation Sandboxed Code Service“ and start the service.

image

Then tried the Visual Studio deployment again, all went fine. Smile

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s